../../_images/first_step.png

Modo Interface Gráfica

A Fig. 10 apresenta uma interface constituída de botões da barra de ferramentas, um seletor de abas representando os arquivos abertos pelo Anatem naquele momento e um editor de texto capaz de realizar análise sintática dos comandos do texto. A barra de tarefas se encontra, originalmente, sob o menu de contexto, mas pode ser movida pelo usuário caso seja do seu interesse).

../../_images/interface.png

Fig. 10 Interface do Anatem para simulação monocaso

Arquivos com modificações pendentes (não salvas) aparecerão com um * junto do seu nome na aba seletora de documentos. O Anatem perguntará ao usuário se deseja salvar os arquivos modificados e que estão sendo utilizados quando requisitar ao programa que inicie a simulação, não sendo necessário salvá-los de antemão.

Tipos de documentos

Para a interface do Anatem, um determinado documento pode ser considerado de duas maneiras distintas: documentos de caso e documento de arquivo de dados (ou simplesmente arquivo). Os arquivos podem ser adicionados ao espaço de trabalho do Anatem pelo comando Arquivo > Abrir Caso ou Arquivo > Abrir Arquivo. A diferença entre ambos os formatos segue:

Caso

é um arquivo de caso de estabilidade para execução, normalmente com extensão stb. Um caso é tratado pelo programa como um arquivo principal, a partir do qual todos os outros dados são chamados. Em geral, neste tipo de arquivo se encontram comandos como TITU, DARQ (ou ULOG) e EXSI. O arquivo que tenha sido aberto como caso é vinculado às funções da interface relativas ao início simulação (F5) e da abertura de arquivos associados. O arquivo caso é identificado por ícone característico ao lado do menu de contexto do programa.

Arquivo

são todos os demais textos ou banco de dados utilizados pelo Anatem, como “BD 1017.blt”, “BD 1017.cdu”, “HVDC 1017.dat”, etc. Esse tipo de arquivo não é interpretado pelo programa como sendo um caso principal de estabilidade, não vinculando funções da barra de tarefas a este arquivo.

Atenção

O arquivo de uma simulação de Anatem (normalmente com extensão .stb) também pode ser aberto através do comando Abrir Arquivo. Quando este procedimento é realizado, o arquivo é tratado como um arquivo de dados comum, não gerando vinculação às funções específicas dos botões da barra de tarefas.

Instruções Básicas

Como localizar caracteres ou palavras específicas

  1. No menu Editar, clique em Localizar

  2. Em Localizar, digite os caracteres ou palavras que você deseja localizar

  3. Clique em Localizar próxima

  • Para localizar somente texto com maiúsculas e minúsculas, como especificado em Localizar, selecione Diferenciar maiúsculas de minúsculas

  • Você pode especificar em que direção pesquisar, partindo do ponto de inserção no arquivo. Em Direção, clique em Acima para pesquisar do ponto de inserção até o início. Clique em Abaixo para pesquisar do ponto de inserção até o final

Como localizar e substituir palavras ou caracteres específicos

  1. No menu Editar, clique em Substituir

  2. Em Localizar, digite os caracteres ou palavras que você deseja localizar

  3. Na caixa Substituir por, digite o texto de substituição

  • Para substituir todas as instâncias do texto de uma vez, clique em Substituir tudo. Para substituir uma instância do texto de cada vez, clique em Localizar próxima e, em seguida, clique em Substituir

  • Ao clicar no botão substituir, caso não exista texto selecionado, a ação executada será a mesma de clicar no botão Localizar

Como ir para uma linha específica

  1. No menu Editar, clique em Ir para

  2. Em Ir para linha, digite o número da linha para a qual o cursor deve ir

Como recortar, copiar, colar ou excluir texto

  • Para recortar um texto a fim de movê-lo para outro local, selecione o texto e, no menu Editar, clique em Recortar

  • Para copiar o texto a fim de colá-lo em outro local, selecione o texto e, no menu Editar, clique em Copiar.

  • Para colar o texto que você tiver recortado ou copiado, posicione o cursor onde deseja colar o texto e, no menu Editar, clique em Colar

  • Para excluir o texto, selecione-o e, no menu Editar, clique em Apagar

Para alterar o estilo e o tamanho da fonte

  1. No menu Ferramentas, clique em Fonte

  2. Faça suas seleções em Fonte, Estilo da fonte e Tamanho

    • Em Exemplo, é exibida uma amostra de como a sua fonte aparecerá

Para simular um caso

  1. No menu Arquivo, clique em Abrir Caso

  2. No menu Simulação, clique em Opções para escolher as opções de visualização durante e após a simulação

  3. No menu Simulação, clique em Executar para iniciar a simulação do caso

  • A qualquer instante, o usuário pode cancelar a simulação clicando no botão cancelar na janela que aparece com a informação do tempo de simulação

Para Inserir Réguas de Dados

  1. Na janela do editor de texto clicar na linha de dados desejada

  2. No menu Editar, clique em Inserir Régua, ou clique no ícone regua da barra de ferramentas

Arquivos Associados ao Anatem

Os arquivos associados são os arquivos apresentados em Arquivos Anatem, podendo serem definidos por meio de comando DARQ (para todos os tipos) ou por meio do comando legado ULOG com as unidades lógicas 1,3,4 e 9 do Anatem. Estes arquivos podem ser abertos por meio do comando no menu “Exibir > Arquivos” ou então por meio do uso de um dos atalhos do seguinte trecho da barra de tarefas toolbar.

Estrutura de Tópicos

Estrutura de Tópicos é um recurso que permite o usuário seletivamente esconder ou mostrar partes do texto que está sendo editado.

Isto permite gerenciar grandes regiões do texto numa janela, enquanto somente a parte relevante do texto está visível. Os Códigos de Execução dos arquivos de dados são definidos, por default, como o titulo da estrutura de tópicos. Esta opção poder ser habilitada ou desabilitada usando o comando Configuração do Editor do menu Ferramentas.

Quando esta opção está selecionada um pequeno espaço é inserido entre o número da linha e o texto onde os símbolos (plus e minus) são mostrados.

Quando os símbolos (plus e minus) são mostrados, o estado do tópico pode ser alternado entre contraído ou expandido, clicando no símbolo.

Atalhos da Barra de Ferramentas

Sendo um editor de texto, o Anatem apresenta atalhos e funções de conhecimento do usuário médio de computação. Algumas novas funcionalidades, contudo, foram contempladas para melhorar a experiência do usuário. A tabela a seguir descreve a função dos botões da barra de tarefas. Em seguida, são apresentados procedimentos detalhados relativos a estas funções por meio dos menus de contexto.

Tabela 3 Tabela de atalhos

Botão

Comando

Atalho

Descrição

../../_images/novo.png

Novo Caso

Ctrl + N

Um novo arquivo do tipo caso é aberto pelo Anatem

../../_images/abrir1.png

Abrir Caso

Ctrl + O

Um arquivo existente do tipo caso é aberto pelo Anatem

../../_images/salvar1.png

Salvar Arquivo

Ctrl + S

Salva o arquivo atual. Caso seja um arquivo novo, uma janela de diálogo é aberta

../../_images/imprimir.png

Imprimir

Ctrl + P

Chama a janela de diálogo de impressão para o arquivo atual

../../_images/recortar.png

Recortar

Ctrl + X

Remove a seleção do texto e adiciona à área de transferência do sistema operacional

../../_images/copiar.png

Copiar

Ctrl + C

Copia a seleção do texto e adiciona à área de transferência do sistema operacional

../../_images/colar.png

Colar

Ctrl + V

Insere no ponto de seleção o texto adicionado à área de transferência do sistema operacional

../../_images/desfazer.png

Desfazer

Ctrl + Z

Desfaz a última operação sobre o texto. Pode ser usado sucessivamente

../../_images/refazer.png

Refazer

Ctrl + Y

Refaz a última operação desfeita pelo desfazer. Pode ser usado sucessivamente

../../_images/coluna.png

Modo Coluna

Alt + C

Ativa/Desativa o modo de inserção em coluna. Neste modo, o usuário pode alterar várias linhas ao mesmo tempo, inserindo em todas um mesmo comando do teclado. As regras de copiar/colar no modo coluna são ligeiramente diferentes do usual

../../_images/comenta.png

Comenta Bloco

Ctrl + R

Comenta o bloco selecionado (o Anatem deixa de interpretar o trecho)

../../_images/descomenta.png

Descomenta Bloco

Ctrl + T

Descomenta o bloco selecionado

../../_images/contrair.png

Contrair Todos

-

Contrai todos os tópicos do arquivo

../../_images/expandir.png

Expandir Todos

-

Expande todos os tópicos do arquivo

../../_images/regua.png

Insere Régua

Ctrl + Shift + R, Ctrl + *

Insere a régua do código de execução

../../_images/branco.png

Espaços em Branco

-

Insere/remove marcador em todos os espaços em branco do arquivo

../../_images/play.png

Simular

-

Executa a simulação associada ao arquivo principal aberto pelo Anatem

../../_images/play_spmd.png

Simular com Paralelismo

F5

Executa a simulação associada ao arquivo principal aberto pelo Anatem com algoritmo SPMD. O número de processadores será determinado automaticamente pelo programa.

../../_images/localizar.png

Localizar

Ctrl + F

Localiza o texto específico dentro do arquivo em questão

../../_images/next.png

Próxima Ocorrência

F3

Avança para a próxima ocorrência na busca

../../_images/prev.png

Ocorrência Anterior

Shift + F3

Volta para a ocorrência anterior

../../_images/replace.png

Substituir

Ctrl + H

Localiza uma expressão e a substitui por outra

../../_images/mark.png

Inserir/Remover Marcador

Ctrl + F2

Insere/remove o marcador de uma linha

../../_images/next_mark.png

Próximo Marcador

F2

Avança até a posição do próximo marcador

../../_images/prev_mark.png

Marcador Anterior

Shift + F2

Retorna até a posição do marcador anterior

../../_images/remove_marker.png

Remove Todos os Marcadores

Ctrl + Shift + F2

Remove todos os marcadores do arquivo

../../_images/dados.png

Arquivo de Dados

Ctrl + Shift + D

Abre uma janela contendo todos os arquivos de dados vinculados ao stb principal. Permite a abertura e o fechamento destes arquivos

../../_images/out1.png

Relatório

Ctrl + Shift + O

Abre o arquivo de relatório (out) do caso no Anatem

../../_images/log2.png

Log de Mensagens

Ctrl + Shift + L

Abre o arquivo de log de mensagens (log) do caso no Anatem

../../_images/csv1.png

Arquivo CSV

Ctrl + Shift + E

Abre os arquivos vinculados do tipo MIIF no executável vinculado a arquivos CSV. Em geral, o Microsoft Office Excel 1

../../_images/plt.png

Arquivo PLT

Ctrl + Shift + P

Abre os arquivos vinculados do tipo PLOT ou RELE no executável Plot

../../_images/cde_b.png

Arquivo CDE

Ctrl + Shift + C

Abre os arquivos vinculados do tipo CDUEdit no executável associado

../../_images/anarede.png

Reestabelecer Caso Histórico

Alt + A

Restabelece o caso histórico utilizado no caso Anatem em uma nova instância do Anarede

../../_images/pacdyn.png

Executar PacDyn

Alt + P

Instancia o PacDyn criando um projeto automaticamente a partir do caso de estabilidade do Anatem

../../_images/7z.png

Compactar Caso (7zip)

-

Utiliza o 7zip incluído na instalação para criar uma versão compacta do caso. Utilizado para facilitar o envio de casos, garantindo que todos os arquivos necessários à simulação estarão presentes.

1

Ou outro programa associado a arquivos do tipo *.csv